[pacman-dev] [PATCH] Remove unused 'z' option from getopt_long's optstring

Nagy Gabor ngaba at bibl.u-szeged.hu
Tue Mar 16 19:47:35 CET 2010


In addition, I permuted shortopts to make it more readable.

Signed-off-by: Nagy Gabor <ngaba at bibl.u-szeged.hu>
---
 src/pacman/pacman.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/src/pacman/pacman.c b/src/pacman/pacman.c
index 750afca..7fe8514 100644
--- a/src/pacman/pacman.c
+++ b/src/pacman/pacman.c
@@ -416,7 +416,7 @@ static int parseargs(int argc, char *argv[])
 		{0, 0, 0, 0}
 	};
 
-	while((opt = getopt_long(argc, argv, "RUDQSTr:b:vkhscVfmnoldepqituwygz", opts, &option_index))) {
+	while((opt = getopt_long(argc, argv, "DQRSTUVb:cdefghiklmnopqr:stuvwy", opts, &option_index))) {
 		alpm_list_t *list = NULL, *item = NULL; /* lists for splitting strings */
 
 		if(opt < 0) {
-- 
1.7.0.2



More information about the pacman-dev mailing list